Skip to main content

Não consigo conectar a minha instância DBaaS

Sintoma

Não é possível conectar a instância DBaaS usando um cliente de banco de dados, como mysql, psql, DBeaver ou outro cliente compatível com a engine.

Causa

A conexão pode falhar quando a instância não está ativa, quando o acesso é feito fora da rede privada da Magalu Cloud, quando a VM de acesso está em outra conta ou região, quando o IP privado está incorreto ou quando usuário e senha foram informados incorretamente.

Solução

Portal

  1. Acesse o Console Magalu Cloud.
  2. No menu principal, clique em Database.
  3. Abra a instância e confirme se o status está ativo.
  4. Copie o IP Privado exibido nos detalhes da instância.
  5. Confirme se você está tentando conectar a partir de uma VM ou recurso na Magalu Cloud, na mesma conta e região da instância DBaaS.
  6. Confira o guia de conexão da engine utilizada:
  7. Verifique se usuário e senha estão corretos.
  8. Se você esqueceu o usuário ou a senha, abra um Ticket de suporte.

CLI

Verifique o status e o IP privado da instância:

mgc dbaas instances get "instance-id"

Substitua instance-id pelo ID da instância.

Para testar a conexão com MySQL a partir de uma VM na mesma conta e região:

mysql -h "ip_privado_do_banco" -u "usuario" -p

Para testar a conexão com PostgreSQL a partir de uma VM na mesma conta e região:

psql -h "ip_privado_do_banco" -U "usuario" -d "postgres"

Se o teste falhar mesmo com status ativo, IP privado correto, usuário correto, senha correta e origem na mesma conta e região, abra um Ticket de suporte informando o erro retornado pelo cliente.